<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="http://jewishjournal.org/xmlrpc.php" />
    <title>In age of uncertainty, Jews must postpone milestones &#8211; Jewish Journal</title>
<meta property="og:type" content="article">
<meta property="og:title" content="In age of uncertainty, Jews must postpone milestones">
<meta property="og:site_name" content="Jewish Journal">
<meta property="og:description" content="As the coronavirus virus (COVID-19) makes travel and large gatherings impossible, a number of North Shore Jews have had to">
<meta property="og:url" content="http://jewishjournal.org/2020/03/25/in-age-of-uncertainty-jews-must-postpone-milestones/">
<meta property="og:locale" content="en_US">
<meta property="og:image" content="http://jewishjournal.org/wp-content/uploads/2020/03/Brodsky-1.jpg">
<meta property="og:image:height" content="569">
<meta property="og:image:width" content="650">
<meta property="article:published_time" content="2020-03-25T18:50:20+00:00">
<meta property="article:modified_time" content="2020-03-25T21:05:02+00:00">
<meta property="article:section" content="Features">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="In age of uncertainty, Jews must postpone milestones">
<meta name="twitter:description" content="As the coronavirus virus (COVID-19) makes travel and large gatherings impossible, a number of North Shore Jews have had to">
<meta name="twitter:url" content="http://jewishjournal.org/2020/03/25/in-age-of-uncertainty-jews-must-postpone-milestones/">
<meta name="twitter:site" content="">
<meta name="twitter:image:src" content="http://jewishjournal.org/wp-content/uploads/2020/03/Brodsky-1.jpg">
<meta name="twitter:image:width" content="650">
<meta name="twitter:image:height" content="569">
			<script type="text/javascript">
              var jnews_ajax_url = 'http://jewishjournal.org/?ajax-request=jnews'
			</script>
			<meta http-equiv="x-dns-prefetch-control" content="on">
<link href="https://app.ecwid.com" rel="preconnect" crossorigin />
<link href="https://ecomm.events" rel="preconnect" crossorigin />
<link href="https://d1q3axnfhmyveb.cloudfront.net" rel="preconnect" crossorigin />
<link href="https://dqzrr9k4bjpzk.cloudfront.net" rel="preconnect" crossorigin />
<link href="https://d3j0zfs7paavns.cloudfront.net" rel="preconnect" crossorigin>
<link rel="prefetch" href="https://d1oxsl77a1kjht.cloudfront.net/css/new?hc=319809216&ownerid=17022359&frontendV2=true">
<link rel="prefetch" href="https://app.ecwid.com/script.js?17022359&data_platform=wporg&lang=en&data_static_home=1&data_g=0000000000" />
<link rel="prerender" href="http://jewishjournal.org/store/" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Jewish Journal &raquo; Feed" href="http://jewishjournal.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Jewish Journal &raquo; Comments Feed" href="http://jewishjournal.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Jewish Journal &raquo; In age of uncertainty, Jews must postpone milestones Comments Feed" href="http://jewishjournal.org/2020/03/25/in-age-of-uncertainty-jews-must-postpone-milestones/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/jewishjournal.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ai1ec_style-css'  href='//jewishjournal.org/wp-content/plugins/all-in-one-event-calendar/cache/60ae84a2_ai1ec_parsed_css.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://jewishjournal.org/wp-includes/css/dashicons.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css'  href='http://jewishjournal.org/wp-includes/css/jquery-ui-dialog.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://jewishjournal.org/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://jewishjournal.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='ecwid-css-css'  href='http://jewishjournal.org/wp-content/plugins/ecwid-shopping-cart/css/frontend.css?ver=6.8.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-css'  href='http://jewishjournal.org/wp-content/plugins/jnews-gallery/assets/css/previewslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-previewslider-responsive-css'  href='http://jewishjournal.org/wp-content/plugins/jnews-gallery/assets/css/previewslider-responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='owlcss-css'  href='http://jewishjournal.org/wp-content/plugins/lgx-owl-carousel/public/assets/lib/owl.carousel2/owl.carousel.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='owltheme-css'  href='http://jewishjournal.org/wp-content/plugins/lgx-owl-carousel/public/assets/lib/owl.carousel2/owl.theme.default.min.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='lgx-owl-carousel-css'  href='http://jewishjournal.org/wp-content/plugins/lgx-owl-carousel/public/assets/css/lgx-owl-carousel-public.css?ver=2.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='http://jewishjournal.org/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://jewishjournal.org/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.13-9993131' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://jewishjournal.org/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='http://jewishjournal.org/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=5.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='http://jewishjournal.org/wp-content/themes/jnews/style.css?ver=5.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='http://jewishjournal.org/wp-content/themes/jnews/assets/css/darkmode.css?ver=5.5.0' type='text/css' media='all' />
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ecwidParams = {"useJsApiToOpenStoreCategoriesPages":"","trackPublicPage":"1","storeId":"17022359"};
/* ]]> */
</script>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/plugins/ecwid-shopping-cart/js/frontend.js?ver=6.8.9'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/plugins/jnews-gallery/assets/js/jquery.previewslider.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"http:\/\/jewishjournal.org\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"15361","token":"577de14600","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.0.1'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/plugins/lgx-owl-carousel/public/assets/lib/owl.carousel2/owl.carousel.js?ver=2.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var lgxcarousel = {"owl_navigationTextL":"http:\/\/jewishjournal.org\/wp-content\/plugins\/lgx-owl-carousel\/public\/assets\/img\/arrow-left.png","owl_navigationTextR":"http:\/\/jewishjournal.org\/wp-content\/plugins\/lgx-owl-carousel\/public\/assets\/img\/arrow-right.png"};
/* ]]> */
</script>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/plugins/lgx-owl-carousel/public/assets/js/lgx-owl-carousel-public.js?ver=2.0.0'></script>
<link rel='https://api.w.org/' href='http://jewishjournal.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://jewishjournal.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://jewishjournal.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Back home, local college students feel uncertain' href='http://jewishjournal.org/2020/03/25/back-home-local-college-students-feel-uncertain/' />
<link rel='next' title='Letter to the Community' href='http://jewishjournal.org/2020/03/25/letter-to-the-community/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="http://jewishjournal.org/" />
<link rel='shortlink' href='http://jewishjournal.org/?p=15361' />
<link rel="alternate" type="application/json+oembed" href="http://jewishjournal.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fjewishjournal.org%2F2020%2F03%2F25%2Fin-age-of-uncertainty-jews-must-postpone-milestones%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://jewishjournal.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fjewishjournal.org%2F2020%2F03%2F25%2Fin-age-of-uncertainty-jews-must-postpone-milestones%2F&#038;format=xml" />
<script data-cfasync="false" type="text/javascript">window.ec = window.ec || Object();
window.ec.config = window.ec.config || Object();
window.ec.config.enable_canonical_urls = true;
</script><script data-cfasync="false" type="text/javascript">
window.ec = window.ec || Object();
window.ec.config = window.ec.config || Object();
window.ec.config.store_main_page_url = 'http://jewishjournal.org/store/';		
</script><!-- Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-134088076-1', 'auto');
  ga('send', 'pageview');

</script>
<!-- End Google Analytics -->
<style> .lgx-carousel-section .lgx-carousel .owl-video-tn{height: 350px; width: 100%;} </style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"http:\/\/jewishjournal.org\/#organization","url":"http:\/\/jewishjournal.org\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["https:\/\/www.facebook.com\/Jewish-Journal-MA-304435508974\/?epa=SEARCH_BOX&jazoest=26510011980109571228979103566699767366816711811190509849756775113104797088741169865105105681089097105110711195865100121749795113101731047311311181551071116795119801181161086780811031181018011852729082537867100746657103112119","https:\/\/twitter.com\/jewish_ma"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"http:\/\/jewishjournal.org\/#website","url":"http:\/\/jewishjournal.org\/","name":"","potentialAction":{"@type":"SearchAction","target":"http:\/\/jewishjournal.org\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script>.thumbnail-container:not(.no_thumbnail).animate-lazy:before, .owl-carousel .owl-item .thumbnail-container:not(.no_thumbnail):before,
.thumbnail-container:after {
	display: none;
}</script><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style><style type="text/css">.no_thumbnail{display: none;}</style>		<style type="text/css" id="wp-custom-css">
			@media only screen and (min-width:1024px) {
	.jeg_pl_lg_5 .jeg_post_title {
		font-size: 34px;
		line-height: 48px;
		margin-bottom: 6px;
	}
}
 
@media (max-width: 1200px) {
}
@media only screen and (max-width: 1024px) {
	.jeg_pl_lg_5 .jeg_post_title {
		font-size: 28px;
		line-height: 38px;
	}
}
@media only screen and (max-width : 667px) {
	.jeg_pl_lg_5 .jeg_post_title {
		font-size: 24px;
		line-height: 34px;
	}
@media only screen and (max-width : 568px) {
}
@media only screen and (max-width : 480px) {
	.jeg_pl_lg_5 .jeg_post_title {
		font-size: 20px;
		line-height: 29px;
	}}}		</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-15361 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jeg_boxed jsc_normal wpb-js-composer js-comp-ver-6.1 vc_responsive">

    
    

    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '><a href='http://jewishjournal.org/2020/03/12/the-jewish-journals-annual-gala-has-been-rescheduled-for-oct-4-2020/' target="_blank" class='adlink ads_image '><img src='http://jewishjournal.org/wp-content/uploads/2020/03/HOUSE_Gala-postponed032420.jpg' alt='' data-pin-no-hover="true"></a><a href='http://jewishjournal.org/2020/03/12/the-jewish-journals-annual-gala-has-been-rescheduled-for-oct-4-2020/' target="_blank" class='adlink ads_image_tablet '><img src='http://jewishjournal.org/wp-content/uploads/2020/03/HOUSE_Gala-postponed032420.jpg' alt='' data-pin-no-hover="true"></a><a href='http://jewishjournal.org/2020/03/12/the-jewish-journals-annual-gala-has-been-rescheduled-for-oct-4-2020/' target="_blank" class='adlink ads_image_phone '><img src='http://jewishjournal.org/wp-content/uploads/2020/03/HOUSE_Gala-postponed032420.jpg' alt='' data-pin-no-hover="true"></a><div class='ads-text'>ADVERTISEMENT</div></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header full">
    <div class="jeg_topbar jeg_container dark">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left  jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
	<ul class="jeg_menu jeg_top_menu"><li id="menu-item-68" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68"><a href="http://jewishjournal.org/about-us/">About Us</a></li>
<li id="menu-item-105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-105"><a href="http://jewishjournal.org/contact/">Contact</a></li>
<li id="menu-item-11118" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11118"><a href="http://jewishjournal.org/archived-issues/">Archived Issues</a></li>
<li id="menu-item-14352" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14352"><a href="http://jewishjournal.org/calendar/">Calendar</a></li>
</ul></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center  jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right  jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        			<div class="jeg_nav_item socials_widget jeg_social_icon_block nobg">
			    <a href="https://www.facebook.com/Jewish-Journal-MA-304435508974/?epa=SEARCH_BOX&jazoest=26510011980109571228979103566699767366816711811190509849756775113104797088741169865105105681089097105110711195865100121749795113101731047311311181551071116795119801181161086780811031181018011852729082537867100746657103112119" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/jewish_ma" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a>			</div>
			<div class="jeg_separator separator1"></div><!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="http://jewishjournal.org/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_nav_item jeg_nav_account">
    <ul class="jeg_accountlink jeg_menu">
        <li>
            <i class="fa fa-spinner fa-spin fa-fw"></i>
        </li>
    </ul>
</div>                    </div>
                </div>

                        </div>
    </div>
</div><!-- /.jeg_container --><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper  jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_top_date">
    Friday, March 27, 2020</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
	    	<a href="http://jewishjournal.org/" style="padding: 0px 20px 0px 0px;">
	    	    <img class='jeg_logo_img' src="http://jewishjournal.org/wp-content/uploads/2018/12/JewishJournal_headline.2.png" srcset="http://jewishjournal.org/wp-content/uploads/2018/12/JewishJournal_headline.2.png 1x, http://jewishjournal.org/wp-content/uploads/2018/12/JewishJournal_headline_retina4.png 2x" alt="Jewish Journal"data-light-src="http://jewishjournal.org/wp-content/uploads/2018/12/JewishJournal_headline.2.png" data-light-srcset="http://jewishjournal.org/wp-content/uploads/2018/12/JewishJournal_headline.2.png 1x, http://jewishjournal.org/wp-content/uploads/2018/12/JewishJournal_headline_retina4.png 2x" data-dark-src="http://jewishjournal.org/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="http://jewishjournal.org/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, http://jewishjournal.org/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x">	    	</a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_nav_html">
    <div style="width: 245px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=104599" width="245" height="63" frameborder="0" scrolling="no"></iframe><a style="float: right;position: relative;height: 63px;display: block;text-indent: -9999em;z-index: 1;margin: -63px 0 0 0;width: 20px" href="https://www.willyweather.com/ma/suffolk-county/downtown-boston.html" rel="nofollow">willy weather</a></div></div>                    </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li id="menu-item-91" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/news/">News</a></li>
<li id="menu-item-9840" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9840 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/features/">Features</a></li>
<li id="menu-item-9839" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9839 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/arts-culture/">Arts &#038; Culture</a></li>
<li id="menu-item-90" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/opinion/">Opinion</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/people/">People</a></li>
<li id="menu-item-9841" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9841 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/youth/">Youth</a></li>
<li id="menu-item-9842" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9842 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/seniors/">Seniors</a></li>
<li id="menu-item-92" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/obituaries/">Obituaries</a></li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header full">
    <div class="jeg_container">
        <div data-mode="fixed" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_fitwidth jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_main_menu_wrapper">
<div class="jeg_nav_item jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_1" data-animation="animate"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9840 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9839 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/arts-culture/">Arts &#038; Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/people/">People</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9841 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/youth/">Youth</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9842 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/seniors/">Seniors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92 bgnav" data-item-row="default" ><a href="http://jewishjournal.org/category/obituaries/">Obituaries</a></li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="http://jewishjournal.org/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="http://jewishjournal.org/">
		        <img class='jeg_logo_img' src="http://jewishjournal.org/wp-content/uploads/2019/03/JewishJournal_headline_300x33_white.png" srcset="http://jewishjournal.org/wp-content/uploads/2019/03/JewishJournal_headline_300x33_white.png 1x, http://jewishjournal.org/wp-content/uploads/2019/03/JewishJournal_headline_300x33_white.png 2x" alt="Jewish Journal"data-light-src="http://jewishjournal.org/wp-content/uploads/2019/03/JewishJournal_headline_300x33_white.png" data-light-srcset="http://jewishjournal.org/wp-content/uploads/2019/03/JewishJournal_headline_300x33_white.png 1x, http://jewishjournal.org/wp-content/uploads/2019/03/JewishJournal_headline_300x33_white.png 2x" data-dark-src="http://jewishjournal.org/wp-content/themes/jnews/assets/img/logo_darkmode.png" data-dark-srcset="http://jewishjournal.org/wp-content/themes/jnews/assets/img/logo_darkmode.png 1x, http://jewishjournal.org/wp-content/themes/jnews/assets/img/logo_darkmode@2x.png 2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="http://jewishjournal.org/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>    <div class="post-wrapper">

        <div class="post-wrap" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">

    <div class="container">

        <div class="jeg_ad jeg_article jnews_article_top_ads">
            <div class='ads-wrapper  '></div>        </div>

        <div class="row">
            <div class="jeg_main_content col-md-8">
                <div class="jeg_inner_content">
                    
                                                <div class="jeg_breadcrumbs jeg_breadcrumb_container">
                            <div id="breadcrumbs"><span class="">
                <a href="http://jewishjournal.org">Home</a>
            </span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
                <a href="http://jewishjournal.org/category/features/">Features</a>
            </span></div>                        </div>
                        
                        <div class="entry-header">
    	                    
                            <h1 class="jeg_post_title">In age of uncertainty, Jews must postpone milestones</h1>

                            
                            <div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_1">

    <div class="meta_left">
                    <div class="jeg_meta_author">
                <img alt='Michael Wittner' src='http://1.gravatar.com/avatar/4c46a1badc6488f85c787e484353fce6?s=80&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/4c46a1badc6488f85c787e484353fce6?s=160&#038;d=mm&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' />                <span class="meta_text">by</span>
                <a href="http://jewishjournal.org/author/mike-wittner/">Michael Wittner</a>            </div>
        
                    <div class="jeg_meta_date">
                <a href="http://jewishjournal.org/2020/03/25/in-age-of-uncertainty-jews-must-postpone-milestones/">March 25, 2020</a>
            </div>
        
                    <div class="jeg_meta_category">
                <span><span class="meta_text">in</span>
                    <a href="http://jewishjournal.org/category/features/" rel="category tag">Features</a>, <a href="http://jewishjournal.org/category/front-page/" rel="category tag">Front Page</a>                </span>
            </div>
        
	        </div>

    <div class="meta_right">
                            <div class="jeg_meta_comment"><a href="http://jewishjournal.org/2020/03/25/in-age-of-uncertainty-jews-must-postpone-milestones/#comments"><i class="fa fa-comment-o"></i> 0</a></div>
            </div>
</div>
</div>
                        </div>

                        <div class="jeg_featured featured_image"><a href="http://jewishjournal.org/wp-content/uploads/2020/03/Brodsky-1.jpg"><div class="thumbnail-container animate-lazy" style="padding-bottom:57.692%"><img width="650" height="375" src="http://jewishjournal.org/wp-content/themes/jnews/assets/img/jeg-empty.png" class="attachment-jnews-750x375 size-jnews-750x375 lazyload wp-post-image" alt="In age of uncertainty, Jews must postpone milestones" data-src="http://jewishjournal.org/wp-content/uploads/2020/03/Brodsky-1-650x375.jpg" data-sizes="auto" data-srcset="" data-expand="700" /></div><p class="wp-caption-text">The Brodsky family of Swampscott, who have had to postpone the bar mitzvah of their son Sam (second from left) until August.</p></a></div>
                        
                        <div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '></div></div>
                        <div class="entry-content no-share">
                            <div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
                                                            </div>

                            <div class="content-inner ">
                                <p class="p4"><span class="s1">As the coronavirus virus (COVID-19) makes travel and large gatherings impossible, a number of North Shore Jews have had to postpone life milestones scheduled for this spring. So what do they do when years of careful planning and joyful anticipation are undone by a silent, invisible threat?</span></p>
<p class="p4"><span class="s1">Some call their rabbi and burst into tears. Carrie Almog of Manchester-by-the-Sea was getting ready to marry her Israeli fiancé, Eli, at the David Citadel Hotel in Jerusalem on April 26. But on March 9, Israel imposed a mandatory 14-day quarantine for all arriving international visitors. A week later, Almog got an email telling her that the hotel would be closed until four days after their wedding. She had no option but to postpone the wedding and the honeymoon on the island of Santorini. </span></p>
<p class="p4"><span class="s1">“I was hysterical at first, but then I talked to Rabbi [Richard Perlman of Temple Ner Tamid in Peabody] and he helped me put it into perspective pretty quickly,” Almog said. “We can replan, and there are a lot of people who are planning funerals.” </span></p>
<p class="p4"><span class="s1">During a crisis that threatens illness, death, and financial ruin, moving a happy day forward a few months becomes more of a nuisance than a catastrophe. “We are happy that everybody we know is home safe and not sick – that’s kind of the bigger concern, because there’s a lot of people out there dealing with a lot worse,” said Maggie Slavet, who recently had to postpone her son Steven’s bar mitzvah, originally planned for March 28 at Temple Emanu-El in Marblehead, to Aug. 29. “It was a big event that we were obviously disappointed to postpone, but we recognize that we’re lucky to be able to have it, and right now we’re just trying to make sure my parents don’t go out food shopping.”</span></p>
<p class="p4"><span class="s1">Another bar mitzvah boy, from Swampscott, also will have to wait. “I think he’d be upset if it were canceled, but because it’s postponed, and he knows he’s gonna have a party and celebrate with his friends, he’s fine – we’re not going to not do it,” said Rori Brodsky of her son Sam, whose May 2 bar mitzvah at Emanu-El was just rescheduled for August. </span></p>
<p class="p4"><span class="s1">Still, postponing a large event is not easy, especially amidst a crisis with no certain endpoint. For that reason, everyone has held off ordering new invitations just yet, and have contingency plans if the new date is still impossible.<span class="Apple-converted-space">  </span>Everyone interviewed praised their rabbis for being flexible and accommodating, and even letting their children recite the Haftorah and/or Torah portion they already learned, regardless of the date. Since all b’nai and b’not mitzvah this spring have been postponed, synagogues are in for a seriously jumbled Parasha schedule later this year.</span></p>
<p class="p4"><span class="s1">Rabbis are offering families different options, including livestreaming a private religious ceremony on the original date and postponing the party till later in the year. Some in the community have opted for this, but everyone interviewed for this article said that it was important their family and friends be present for the moment.</span></p>
<figure id="attachment_15364" aria-describedby="caption-attachment-15364" style="width: 350px" class="wp-caption alignleft"><img class="size-full wp-image-15364" src="http://jewishjournal.org/wp-content/uploads/2020/03/Maya-Goss-1.jpg" alt="" width="350" height="467" srcset="http://jewishjournal.org/wp-content/uploads/2020/03/Maya-Goss-1.jpg 350w, http://jewishjournal.org/wp-content/uploads/2020/03/Maya-Goss-1-225x300.jpg 225w" sizes="(max-width: 350px) 100vw, 350px" /><figcaption id="caption-attachment-15364" class="wp-caption-text">Maya Gross, of Wakefield, postponed her bat mitzvah until September.</figcaption></figure>
<p class="p4"><span class="s1">“I think [Maya’s] biggest thing is she wants important people in her life, her immediate family and also her friends to come,” said Liza Goss of Wakefield, who just had to postpone her daughter’s May 9 bat mitzvah at Temple Ner Tamid until Sept. 5. “I originally thought my only option would be to somehow video the service and move the party, but my Maya was really not feeling good about that, so the rabbi helped us understand that this is extenuating circumstances.”</span></p>
<p class="p4"><span class="s1">However, everyone said that they would consider this option if they had to postpone a second time because their children already need to extend their training and practice to remember everything for the later date. Some are considering creative solutions. “My niece who lives in Swampscott and goes to the same temple [Emanu-El] is scheduled to have hers for Oct. 17, so we talked about if we couldn’t find another date possibly doing it together,” said Brodsky of pairing with her son, Sam. “Otherwise, I do think I would do the religious part and have the party later, because I do think that it would be a lot for [Sam] to have to keep that going, because it’s a lot of material that he’s learned.” </span></p>
<p class="p4"><span class="s1">Everyone praised their rabbis and vendors for being accommodating and helping them find new dates that worked. Miraculously, each family was able to find a new date that worked for the temple, photographer, band, DJ, and more, all while trying to coordinate a record-breaking number of postponements and cancellations. </span></p>
<p class="p4"><span class="s1">“The woman at the DJ company has to reschedule 37 events, and I’m sure she’s dealing with her own personal challenges,” said Brodsky. “But everyone just wants to help everyone out.” </span></p>
                                
	                            
                                                            </div>

                            
                                                    </div>

                        <div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"><div class="jeg_prevnext_post">
            <a href="http://jewishjournal.org/2020/03/25/back-home-local-college-students-feel-uncertain/" class="post prev-post">
            <span class="caption">Previous Post</span>
            <h3 class="post-title">Back home, local college students feel uncertain</h3>
        </a>
    
            <a href="http://jewishjournal.org/2020/03/25/letter-to-the-community/" class="post next-post">
            <span class="caption">Next Post</span>
            <h3 class="post-title">Letter to the Community</h3>
        </a>
    </div></div><div class="jnews_author_box_container"></div><div class="jnews_related_post_container"></div><div class="jnews_popup_post_container">
    <section class="jeg_popup_post">
        <span class="caption">Next Post</span>

                    <div class="jeg_popup_content">
                <div class="jeg_thumb">
                                        <a href="http://jewishjournal.org/2020/03/25/letter-to-the-community/">
                        <div class="thumbnail-container animate-lazy no_thumbnail size-1000 "></div>                    </a>
                </div>
                <h3 class="post-title">
                    <a href="http://jewishjournal.org/2020/03/25/letter-to-the-community/">
                        Letter to the Community                    </a>
                </h3>
            </div>
                
        <a href="#" class="jeg_popup_close"><i class="fa fa-close"></i></a>
    </section>

</div><div class="jnews_comment_container">	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/25/in-age-of-uncertainty-jews-must-postpone-milestones/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://jewishjournal.org/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='15361' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ddb9f08cf5" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="10"/></p></form>	</div><!-- #respond -->
	</div>
                                    </div>
            </div>
            
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
    <div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-6"><div  class='jeg_ad jeg_ad_module jnews_module_15361_0_5e7dbbc506612   '><div class='ads-wrapper'><a href='rosenberg@jewishjournal.org' target='_blank' class='adlink ads_image '><img src='http://jewishjournal.org/wp-content/uploads/2018/12/ad_300x600.png' alt='' data-pin-no-hover="true"></a></div></div></div><div class="widget widget_text" id="text-18"><div class="jeg_block_heading jeg_block_heading_6 jnews_5e7dbbc506800"><h3 class="jeg_block_title"><a href='https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=Z5VSKBEUW2PQ6&source=url'><span>Donate to the Journal</span></a></h3></div>			<div class="textwidget"><p><img class="alignnone size-full wp-image-8622" src="http://jewishjournal.org/wp-content/uploads/2018/12/donate_cards.2.png" alt="" width="819" height="112" /></p>
</div>
		</div></div>        </div>

        <div class="jeg_ad jeg_article jnews_article_bottom_ads">
            <div class='ads-wrapper  '></div>        </div>

    </div>
</div>
                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-15361 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_1 jnews jeg_boxed jsc_normal wpb-js-composer js-comp-ver-6.1 vc_responsive"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_4 normal">
    <div class="jeg_footer_container jeg_container_full">
        <div class="jeg_footer_content">
            <div class="container">
                <div class="row">
                    <div class="jeg_footer_primary clearfix">
                        <div class="col-md-9 footer_column">
                            <ul class="jeg_menu_footer"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="http://jewishjournal.org/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9840"><a href="http://jewishjournal.org/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9839"><a href="http://jewishjournal.org/category/arts-culture/">Arts &#038; Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90"><a href="http://jewishjournal.org/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="http://jewishjournal.org/category/people/">People</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9841"><a href="http://jewishjournal.org/category/youth/">Youth</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9842"><a href="http://jewishjournal.org/category/seniors/">Seniors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="http://jewishjournal.org/category/obituaries/">Obituaries</a></li>
</ul>                        </div>
                        <div class="col-md-3 footer_column footer_right">
                            <div class="footer-text">
                                <strong> Tel: (978) 745-4111 </strong>                            </div>
                        </div>
                    </div>

                    
                    <div class="jeg_footer_secondary clearfix">
                        <div class="col-md-9 footer_column">
                            <p class="copyright"> © 2019 <a href="http://jewishjournal.org" title="3">Jewish Journal </a> </p>
                        </div>
                        <div class="col-md-3 footer_column footer_right">

                            			<div class="jeg_social_icon_block socials_widget nobg">
	            <a href="https://www.facebook.com/Jewish-Journal-MA-304435508974/?epa=SEARCH_BOX&jazoest=26510011980109571228979103566699767366816711811190509849756775113104797088741169865105105681089097105110711195865100121749795113101731047311311181551071116795119801181161086780811031181018011852729082537867100746657103112119" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/jewish_ma" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a>	        </div>
			
                        </div>
                    </div>

                                        
                </div>
            </div>
        </div>
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="http://jewishjournal.org/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-91"><a href="http://jewishjournal.org/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9840"><a href="http://jewishjournal.org/category/features/">Features</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9839"><a href="http://jewishjournal.org/category/arts-culture/">Arts &#038; Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-90"><a href="http://jewishjournal.org/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="http://jewishjournal.org/category/people/">People</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9841"><a href="http://jewishjournal.org/category/youth/">Youth</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9842"><a href="http://jewishjournal.org/category/seniors/">Seniors</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-92"><a href="http://jewishjournal.org/category/obituaries/">Obituaries</a></li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://www.facebook.com/Jewish-Journal-MA-304435508974/?epa=SEARCH_BOX&jazoest=26510011980109571228979103566699767366816711811190509849756775113104797088741169865105105681089097105110711195865100121749795113101731047311311181551071116795119801181161086780811031181018011852729082537867100746657103112119" target='_blank' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com/jewish_ma" target='_blank' class="jeg_twitter"><i class="fa fa-twitter"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© 2019 <a href="http://jewishjournal.org" title="3">Jewish Journal </a></p>
</div>    </div>
</div>    </div>
</div><!-- Login Popup Content -->
<div id="jeg_loginform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform">
        <form action="#" method="post" accept-charset="utf-8">
            <p>Login to your account below</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
            <p class="input_field">
                <input type="password" name="password" placeholder="Password" value="">
            </p>
            <p class="submit">
                <input type="hidden" name="action" value="login_handler">
                <input type="hidden" name="jnews_nonce" value="1e4b7b3fc8">
                <input type="submit" name="jeg_login_button" class="button" value="Log In" data-process="Processing . . ." data-string="Log In">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_forgotform" class="jeg_popuplink forgot">Forgotten Password?</a>
                            </div>
        </form>
    </div>
</div>

<!-- Register Popup Content -->
<div id="jeg_registerform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform">
        <form action="#" method="post" accept-charset="utf-8">
            <p>Fill the forms bellow to register</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="email" placeholder="Your email" value="">
            </p>
            <p class="input_field">
                <input type="text" name="username" placeholder="Username" value="">
            </p>
            <p class="submit">
                <input type="hidden" name="action" value="register_handler">
                <input type="hidden" name="jnews_nonce" value="">
                <input type="submit" name="jeg_login_button" class="button" value="Sign Up" data-process="Processing . . ." data-string="Sign Up">
            </p>
                        <div class="bottom_links clearfix">
                <span>All fields are required.</span>
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div>


<!-- Register Popup Content -->
<div id="jeg_forgotform" class="jeg_popup mfp-with-anim mfp-hide">
    <div class="jeg_popupform">
        <form action="#" method="post" accept-charset="utf-8">
            <h3>Retrieve your password</h3>
            <p>Please enter your username or email address to reset your password.</p>

            <!-- Form Messages -->
            <div class="form-message"></div>

            <p class="input_field">
                <input type="text" name="user_login" placeholder="Your email or username" value="">
            </p>
            <p class="submit">
                <input type="hidden" name="action" value="forget_password_handler">
                <input type="hidden" name="jnews_nonce" value="">
                <input type="submit" name="jeg_login_button" class="button" value="Reset Password" data-process="Processing . . ." data-string="Reset Password">
            </p>
            <div class="bottom_links clearfix">
                <a href="#jeg_loginform" class="jeg_popuplink"><i class="fa fa-lock"></i> Log In</a>
            </div>
        </form>
    </div>
</div><script type="text/javascript">var jfla = ["desktop_login","login_form"]</script>            <script>
                (function (i, s, o, g, r, a, m) {
                    i['GoogleAnalyticsObject'] = r;
                    i[r] = i[r] || function () {
                        (i[r].q = i[r].q || []).push(arguments)
                    }, i[r].l = 1 * new Date();
                    a = s.createElement(o),
                        m = s.getElementsByTagName(o)[0];
                    a.async = 1;
                    a.src = g;
                    m.parentNode.insertBefore(a, m)
                })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga');

                ga('create', 'UA-132847886-1', 'auto');
                ga('send', 'pageview');
            </script>
			        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        <div class="jeg_read_progress_wrapper"></div><script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/resizable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/draggable.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/button.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/position.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/jquery/ui/dialog.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/wpdialog.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/jewishjournal.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.13-9993131'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jnewsoption = {"popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","lang":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"15361","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"top_right","rtl":"0","gif":"","site_slug":"\/","site_domain":"jewishjournal.org"};
/* ]]> */
</script>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=5.5.0'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://jewishjournal.org/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=5.5.0'></script>
<![endif]-->
<script type='text/javascript' src='http://jewishjournal.org/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='http://jewishjournal.org/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"In age of uncertainty, Jews must postpone milestones","published":"2020-03-25 14:50:20","updated":"2020-03-25 21:05:02"}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"http:\/\/jewishjournal.org","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"http:\/\/jewishjournal.org\/category\/features\/","name":"Features"}},{"@type":"ListItem","position":3,"item":{"@id":"http:\/\/jewishjournal.org","name":"Home"}},{"@type":"ListItem","position":4,"item":{"@id":"http:\/\/jewishjournal.org\/category\/features\/","name":"Features"}}]}</script>
</body>
</html>
